Scheduled Maintenance

Incident Report for Helium Mobile

Resolved

Maintenance has concluded. Claiming is operating as expected.
Posted Jun 05, 2025 - 13:02 PDT

Monitoring

A second iteration of this morning's maintenance is underway. Please note that reward claiming for legacy accounts may be temporarily unavailable for the next hour.
Posted Jun 05, 2025 - 10:31 PDT
This incident affected: Rewards Claiming.