Unplanned Outage

Incident Report for Helium Mobile

Resolved

This issue has been resolved. All systems are operating as expected.
Posted Apr 06, 2026 - 13:21 PDT

Investigating

We are currently experiencing an outage related to our connection to our carrier partner. Some functionality including new plan sign ups, SIM installation usage information, add on purchases, and plan changes may be unavailable. Calls, text, and data usage are not affected.
Posted Apr 06, 2026 - 12:11 PDT
This incident affected: Helium Mobile Subscriber Sign Up and SIM Changes: Porting and Activation.