Port Out Delays
Incident Report for Helium Mobile
Resolved
This incident has been resolved.
Posted May 08, 2024 - 12:34 PDT
Investigating
We are currently experiencing delays related to port outs and are waiting on a fix. Other subscriber services are not affected, such as calling, texting, and data services.
Posted May 07, 2024 - 10:35 PDT
This incident affected: Helium Mobile Service.