Intermittent issues with signing in, payment transactions, claiming rewards, and discovery mapping
Incident Report for Helium Mobile
Resolved
This incident has been resolved.
Posted May 09, 2024 - 10:39 PDT
Investigating
Due to an issue with a third-party service, Helium Mobile App users may see intermittent issues with signing into their account, sending payments, receiving payments, claiming rewards (free or paid), and discovery mapping.

Consistent notifications may indicate issues with Discovery Mapping. Users may try to fix the issue by deleting the app and re-installing the app or turning off Discovery Mapping for the time being.

Voice, Data, and Texting services are not affected.
Posted May 03, 2024 - 08:01 PDT
This incident affected: Helium Mobile Subscriber Sign Up, Mapping, and Rewards Claiming.