Hotspot Dashboard Outage

Incident Report for Helium Mobile

Resolved

The issue impacting hotspot connectivity and dashboard access has been resolved. Backend services have fully recovered, and hotspots should now be operating normally. We’ll continue to monitor systems to ensure ongoing stability. Thank you for your patience.
Posted Jul 11, 2025 - 13:51 PDT

Monitoring

Backend services have been restored, and hotspots are now in the process of recovering their configuration. Hotspots should begin returning to normal operation shortly. We are actively monitoring the recovery to ensure full stability.
Posted Jul 11, 2025 - 08:54 PDT

Update

The team has identified a potential root cause and is actively working to validate and resolve it while bringing affected systems back online. Will continue to update the community on progress.
Posted Jul 11, 2025 - 08:34 PDT

Investigating

We are currently investigating a widespread outage that began approximately 4 hours ago (6 am EST). Affected systems include offline hotspot reporting and an inaccessible hotspot dashboard. Our team is actively working to identify the root cause and restore full functionality as quickly as possible. Updates will follow as we make progress.
Posted Jul 11, 2025 - 07:39 PDT
This incident affected: Wi-Fi Hotspots.