Tax Calculation Issue
Incident Report for Helium Mobile
Resolved
This incident has been resolved.
Posted May 08, 2024 - 14:28 PDT
Investigating
Our tax partner is currently experiencing degraded performance, which may result in taxes and fees not calculating during signup and payment estimate fields remaining blank. We are currently investigating this issue.
Posted May 08, 2024 - 13:37 PDT
This incident affected: Helium Mobile Subscriber Sign Up.