Carrier Partner Outage

Incident Report for Helium Mobile

Resolved

This outage has been resolved.
Posted Jul 28, 2026 - 07:08 PDT

Monitoring

According to our carrier partner, the outage has been resolved. We are continuing to monitor the situation.
Posted Jul 27, 2026 - 21:16 PDT

Investigating

Due to an outage with our carrier partner, some subscribers may experience gaps in service. Connectivity to the Helium Network through Helium Hotspots is not impacted by this outage.

We are monitoring this situation and will update when we receive new information from our carrier partner.
Posted Jul 27, 2026 - 16:50 PDT
This incident affected: Helium Mobile Service.