Sign up and support access issues
Incident Report for Helium Mobile
Resolved
This incident has been resolved.
Posted Dec 09, 2023 - 06:59 PST
Identified
One of the backend services has failed due to infrastructure provider changes.

We have identified the offending device but signups and support functions will be affected until a fix is deployed
Posted Dec 09, 2023 - 00:16 PST
This incident affected: Helium Mobile Subscriber Sign Up and Support.