Currently Unavailable: Account Changes and New Account Creations
Incident Report for Helium Mobile
Resolved
This incident has been resolved
Posted Nov 19, 2024 - 10:45 PST
Investigating
Due to an issue with our network partner, certain features related to account changes and new account creation are currently unavailable. We are monitoring the situation and will update once a fix has been identified.

Communication services such as sending and receiving calls and texts or using data are not affected.
Posted Nov 16, 2024 - 15:59 PST
This incident affected: Helium Mobile Service and Helium Mobile Subscriber Sign Up.