Unplanned Outage

Incident Report for Helium Mobile

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 13:57 PDT

Update

We are continuing to investigate this issue.
Posted Apr 10, 2025 - 12:30 PDT

Investigating

Due to an unplanned outage with our carrier partner, some account-based services are not available. Actions including account activations, phone number porting, SIM changes, and others may not be available at this time. Communication services like calling, texting, and data usage are not impacted.
Posted Apr 10, 2025 - 12:28 PDT
This incident affected: Helium Mobile Subscriber Sign Up.