Transaction slowdown
Incident Report for Helium Mobile
Resolved
Transactions processing normally.
Posted Apr 09, 2024 - 13:13 PDT
Investigating
Due to high levels of active, you may experience delays setting up Hotspots or with transactions affecting transferring, claiming, and paying with MOBILE in the Helium Mobile app. Texting, calling, and internet use are not affected.
Posted Apr 09, 2024 - 12:38 PDT
This incident affected: Solana Blockchain Services.