Scheduled Maintenance

Incident Report for Helium Mobile

Resolved

Maintenance has concluded, claiming should be functioning as expected.
Posted Jun 05, 2025 - 09:21 PDT

Investigating

We are conducting scheduled maintenance this morning. During this maintenance window, there may be downtime for claiming token rewards for subscribers on legacy plans. This is expected to last about one hour.
Posted Jun 05, 2025 - 09:07 PDT
This incident affected: Rewards Claiming.