Delays in Transactions due to Solana Blockchain Activity

Incident Report for Helium Mobile

Resolved

This incident has been resolved.
Posted Jan 31, 2024 - 14:00 PST

Monitoring

Blockchain activity may be high on Wednesday, due to the Jupiter airdrop. You may experience delays setting up Hotspots or with transactions affecting transferring, claiming, and prepaying MOBILE in the Helium Mobile app.
Posted Jan 31, 2024 - 07:44 PST
This incident affected: Solana Blockchain Services.