Gift Card Redemption Currently Unavailable

Incident Report for Helium Mobile

Resolved

This issue has been resolved. Gift cards are now redeemable. Thanks for your patience.
Posted Apr 18, 2025 - 14:03 PDT

Investigating

Due to high demand, gift card redemption is temporarily unavailable. We are looking into this issue and will post an update once it has been addressed.
Posted Apr 18, 2025 - 13:02 PDT
This incident affected: Rewards.