Unplanned Outage: Data Usage Updates

Incident Report for Helium Mobile

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 13:30 PST

Investigating

Due to an outage with our carrier partner, your data usage metrics in the Helium Mobile App may not accurately reflect actual usage rates. We are currently investigating this issue.
Posted Feb 18, 2026 - 08:48 PST
This incident affected: Helium Mobile Service.