Temporary Unavailability of SIM Cards for Zero Plan

Incident Report for Helium Mobile

Update

We are continuing to work on a fix for this issue.
Posted Oct 23, 2025 - 15:29 PDT

Identified

Physical SIM cards are temporarily unavailable to order for Zero Plan activations. eSIMs are still available for all subscribers. Paid plan orders are not affected.

We are working to restock availability as soon as possible.
Posted Oct 23, 2025 - 12:49 PDT
This incident affects: Helium Mobile Service.