Transaction Slowdown
Incident Report for Helium Mobile
Resolved
Transactions should be processing normally at this time.
Posted Apr 23, 2024 - 10:04 PDT
Investigating
Due to a partial server outages, you may see a delay in blockchain-related transactions including claiming, transferring, paying with MOBILE, and onboarding hotspots. Talk, text, and data services are not affected.
Posted Apr 22, 2024 - 11:58 PDT
This incident affected: Solana Blockchain Services and Rewards Claiming.