Transaction Slowdown
Incident Report for Helium Mobile
Resolved
This has been resolved.
Posted Apr 01, 2024 - 08:28 PDT
Investigating
Due to transaction congestion on the Solana blockchain, you may experience delays setting up Hotspots or with transactions affecting transferring, claiming, and prepaying MOBILE in the Helium Mobile app. Ability to view badges and token balances may also be affected. Texting, calling, and internet use are not affected.
Posted Mar 30, 2024 - 17:33 PDT
This incident affected: Solana Blockchain Services.