Helium Mobile App Outage
Incident Report for Helium Mobile
Resolved
The issue has been resolved. All features appear to be functioning as expected. We will continue to monitor activity and update if anything changes.
Posted Apr 24, 2024 - 12:32 PDT
Update
We are continuing to investigate this issue.
Posted Apr 24, 2024 - 12:11 PDT
Investigating
Helium Mobile is currently experiencing an application outage. This does not affect call, text, or data services, but during the outage subscribers may not be able to log into the Helium Mobile App, view their Discovery Mapping feed, or access other features related to the app. This also affects new user signup. We are currently investigating the issue.
Posted Apr 24, 2024 - 12:08 PDT
This incident affected: Helium Mobile Subscriber Sign Up, Mapping, and Rewards Claiming.