Usage Reporting Issue

Incident Report for Helium Mobile

Resolved

This incident has been resolved
Posted Jun 16, 2026 - 11:01 PDT

Monitoring

A fix has been deployed and we are monitoring. Usage should display as expected.
Posted Jun 15, 2026 - 13:01 PDT

Investigating

Due to an error in records processing, some Helium Mobile subscribers may see elevated usage reported in their Helium Mobile app and receive inaccurate notifications related to their data consumption. We are investigating this issue. This issue is exclusive to reporting and notification. Affected subscribers will not be throttled or capped on their data usage.
Posted Jun 14, 2026 - 11:38 PDT