Transaction Slowdown
Incident Report for Helium Mobile
Resolved
Solana blockchain congestion resolved.
Posted Mar 19, 2024 - 08:46 PDT
Investigating
Blockchain activity is high today. You may experience delays setting up Hotspots or with transactions affecting transferring, claiming, and prepaying MOBILE in the Helium Mobile app. Texting, calling, and internet use are not affected.
Posted Mar 15, 2024 - 16:15 PDT
This incident affected: Solana Blockchain Services.