Helium Mobile Sign Up Verification Issues

Incident Report for Helium Mobile

Resolved

We've resolved the issue. If you tried to sign up between 12:57pm PT and 2:35pm PT today (June 16), please close and reopen the app and proceed through the verification flow again. There is no need to contact support.

Thanks again for your patience.
Posted Jun 16, 2025 - 14:38 PDT

Identified

The team has identified an issue where customers signing up are unable to pass identity verification. We'll be fixing the issue and should have a resolution shortly.
Posted Jun 16, 2025 - 13:38 PDT
This incident affected: Helium Mobile Subscriber Sign Up.