Customers cannot sign up for a Helium Mobile plan

Incident Report for Helium Mobile

Resolved

We're seeing sign ups again, closing this issue as resolved. Apologies for the inconvenience.
Posted May 29, 2025 - 20:57 PDT

Monitoring

We've identified the issue and rolled back a change. Signing up for Helium Mobile is expected to come back over the next view minutes.
Posted May 29, 2025 - 20:48 PDT

Investigating

We're currently investigating why users cannot create new accounts to sign up for a Helium Mobile subscription.
Posted May 29, 2025 - 20:37 PDT
This incident affected: Helium Mobile Subscriber Sign Up.